
Tom Brughmans Network Analysis with Cytoscape Tutorial November 2013 

 1 

Network Analysis with Cytoscape Tutorial 

Please refer to this tutorial as: Brughmans, T. 2013. Network Analysis with 
Cytoscape Tutorial, November 2013. 

Please cite the case study and dataset used here as: Brughmans, T., Keay, S., and 
Earl, G. Submitted. Just points and lines? Exponential random graph models for 
evaluating the changing role of visibility between urban settlements in Iron Age 
and Roman Southern Spain, Journal of Archaeological Method and Theory. 
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In this practical you will learn how to create, visualise and analyse networks 
using Cytoscape (http://cytoscape.org/), and how to export the results of these 
analyses. This practical is conceived as an introduction to exploratory network 
analysis for the Humanities, using an archaeological/geographical example. 

Download the files needed for this practical. These should include: ‘network.xls’ 
and ‘network_attributes.xls’. 

1. Cytoscape interface 
Open Cytoscape from the Windows programs menu. 

After loading the software Cytoscape will show you a welcome screen. Select 
‘New/Empty Network’: 

 

Accept the default options in the ‘create new network’ window: 
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Always start by saving a new session. Select File > Save As from the top menu. A 
dialogue box appears, select the location where you want to save the new session 
file and click the Save button. The name of your session will now appear at the 
top of your Cytoscape window. Cytoscape saves sessions in its own format, the 
session files always end in ‘.cys’. 

There are three main parts to the Cytoscape interface: the control panel, table 
panel and workspace. 

Firstly, on the left hand side is the Control Panel, which has three different tabs 
called Network, VizMapper and Filters. The Network tab will list all the networks 
that you have imported or opened, which is why it is now empty. The VizMapper 
tab allows you to apply visual styles to your network and modify every aspect of 
how they are represented (see section 7 below). The Filters tab allows you to 
create and modify filters to make custom selections from the network (see 
section 4 below). 

Secondly, at the bottom of the screen you will find the Table Panel. This is where 
you can browse through selected nodes, edges, networks and their attributes. 
The table panel should be empty now. The five buttons at the top left of the Table 
Panel are of interest. The first one allows you to change the table mode, the 
second one to click attributes on and off, the third one to click ALL attributes on 
and the fourth one off, the fifth one allows you to create new attributes. The final 
one allows you to delete attributes. 

Thirdly, the black space in between the Control Panel and the Table Panel is your 
workspace. This is where network windows will show up once you created them. 
Within network windows you can make selections and modify the position of 
nodes, as you will see in section 5. 
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2. Network input files 
To create a network you can either make it manually (which will not be covered 
in this practical) or you can import it from other files. In order to create 
networks you will need only one thing: a list of all edges or arcs between all 
nodes (an edge is a line without a direction that connects two points, an arc on 
the other hand does have a direction, e.g. from node A to node B). These kinds of 
lists can be very simple as we will see below. In addition to this list we might 
want to import information about these edges or arcs. This information takes the 
form of ‘attributes’ of the arcs or edges. At this point we still do not have any 
information about the nodes, however. To import information on nodes we will 
need a list of all individual nodes and their attributes. In this section we will have 
a first look at this data needed to create networks. 

Cytoscape can import many different file types. In this practical we will use 
Microsoft Excel spreadsheets. 

The two files you downloaded are Excel spreadsheets: ‘network.xls’ and 
‘network_attributes.xls’. 

Now we will open these two files in Microsoft Excel (or an alternative 
spreadsheet programme) to see what kind of data is needed to make networks. 
First, open ‘network.xls’ in Microsoft Excel. Scroll all the way up to the top of this 
long document if necessary. 

You will see that this spreadsheet consists of nine columns with information. At 
the top of the spreadsheet the first row describes what kind of information is 
stored in each column: 

line ID from node to node probability length from x from y to x to y 

 

It might not look like a network now, but this spreadsheet actually contains all 
the information we need to create a really large and complex web of 
relationships. Every row describes an arc (or directed relationship): the arc 
starts with the ‘from node’ described as a numerical identifier in the first column 
(e.g. 2) and ends in the ‘to node’ also described as a number in the third column. 
All the other columns hold information on these edges, like the probability of an 
arc, its length, its number, and X and Y geographical coordinates of its endpoints. 

You might wonder at this point what all these arcs represent. This specific list of 
information describes 190 archaeological sites (the ‘from’ and ‘to’ nodes) and 
each site was given a unique number (in column ‘from node’ and ‘to node’, e.g. 2). 
This list describes a visibility network: the directed lines that go from one node 
to the other represent lines of sight. For example, we could read the first row in 
the list like this: “arc number 1 indicates that an observer at site 2 can see site 
445 about 9% of the time, and this line of sight has a length of 10km”. The 
creation of these lines of sight and this network is described in the figure below: 
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In this picture we see an observer located on point (a) at site B. This observer 
can see point (c) at site A with a certain probability. On the latter site another 
observer can see point (a) at site B with a given probability. We can describe this 
type of information as a network (d) by representing each site (or at least the 
observer location selected for a site) as a node and connecting them with 
directed lines (arcs) if from one site the other can be seen. 

This is a geographical visualisation of the visibility network, limited to lines of 
sight with a length up to 50km: 

 

What is the advantage of looking at this information as a purely topological 
network rather than a geographically projected network? Why don’t we just 
stare at maps in a GIS? It is important to stress that these different techniques 
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are by no means mutually exclusive. They complement each other by focusing on 
different aspects of the same dataset. The advantage of the network approach is 
that: 

 It allows us to visualise this large number of interactions in an explicit 
way 

 It forces us to think through interactions between sites. Links of visibility 
between sites could indicate that direct communication between these 
sites through signalling might have occurred. Sites can also exercise visual 
control over a surrounding landscape and the sites within this landscape. 
A visibility network will also tell us which sites can be seen from many 
other sites and from which sites many other sites can be seen. 
Archaeologists might be interested in exploring if such visual prominence 
was intentional and what role it played in structuring the interactions 
between past communities. 

 We can explore the structure of all these interactions combined 
 We can analyse both the role of individual nodes, as well as the structure 

of the network as a whole 

We will do most of these things in the second part of the practical! 

First we will have a look at the second file we downloaded. Open 
‘network_attributes.xls’ in Microsoft Excel. Scroll to the top of the spreadsheet if 
necessary. 

The spreadsheet has seven different columns, each holding a different type of 
information about the nodes. These are the node attributes. The top row of the 
spreadsheet describes what kind of information is stored in each column: 

SiteID Site name Iberian Republican 

Early 

Imperial 

Middle 

Imperial 

Late 

Imperial 

 

The first column (‘SiteID’) is the unique code for each site that we have also 
encountered in the first file we opened (as from node and to node). This column 
will allow us to link this list of attributes with the list of arcs. All the other 
columns are attributes of the nodes. The column titled ‘Site name’ holds the 
name by which the site is known, and we will use this as a label for the nodes. 
The next five columns are date ranges of periods: Iberian (Iron Age), Roman 
Republican, Early Imperial, Middle Imperial, and Late Imperial. A value of 1 
indicates that a site was occupied during this period, and 0 means it was not. 
These columns will allow us to explore how this network of visibility changes 
through time. 

3. Import network 
We will now use the two spreadsheets that we looked at in the previous section 
to create networks. 
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In Cytoscape click File > Import > Network > File…. A dialogue box appears 
that looks like this: 

 

Browse to ‘network.xls’, select it and click open. A new dialogue box appears. 
You will see that the preview box at the bottom shows part of the spreadsheet: 

 

The first thing we need to do now is make sure that Cytoscape knows the first 
row holds the labels. To do this, click the box in front of Show Text File Import 
Options. The dialogue box is now extended like this: 
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Click on the box in front of Transfer first line as attribute names. This will do 
exactly as it says: the first row of the spreadsheet will be used to label the data in 
the columns. Next we will have to specify which column holds the starting points 
for the arcs and which column holds the end points. Note that since our lines of 
sight have a direction it is extremely important to get the order right: the source 
is the ‘from node’ and the target is the ‘to node’. To do this, click on the drop 
down box for Source Interaction and select the relevant column. Notice how 
this column now shows a V sign next to the label and is coloured purple. Next 
click on the drop down box of Target Interaction and select the relevant 
column. This column is now coloured orange. Now we will have to select all the 
other columns as arc attributes: this is extra information on the arcs that we can 
use to explore the network. Click once on each of the remaining column labels in 
turn, notice how they turn blue when selected. Your screen should now look like 
this: 
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Now we are ready to import. Click the OK button at the bottom of this dialogue 
box. The network will be loaded into your Cytoscape session, this may take some 
time. When it is successfully loaded a dialog box will appear that tells you the 
network has been successfully loaded. 

Your Cytoscape window will now look completely different. On the Control Panel 
you will have a new line highlighted and titled ‘Sheet1’. This is the first network 
you imported. At the bottom of the Control Panel an overview of your entire 
network is given. If you place your cursor in this panel, click and drag you will be 
able to move the view. In the workspace you will have a new window that shows 
your network: 
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You might want to save your session again at this point! 

First of all, let’s rename the network so that we remember what data it holds 
once we have more networks. Right click the ‘sheet1’ in the Control Panel and 
select Rename Network. A new dialogue box will appear. Give the network the 
name ‘complete network’ and click ok. 

You can maximise your network window to see it more clearly and explore it a 
bit. You can zoom in and out with your mouse wheel, you can select and move 
nodes with your left mouse button. By clicking and dragging inside the network 
overview box below the Control Panel you can change the view in your network 
window to different sections of the network. You can also do this by clicking and 
dragging the mouse wheel inside the network view. The network now shows a 
regular Rectangular layout, we will change this to something more interesting in 
section 5 of the practical. 

This network now only consists of nodes, arcs and arc attributes. What we have 
to do now is import the node attributes. To do this select File > Import > Table 
> File. Browse to the location of ‘network_attributes.xls’, select it and click OK. A 
new dialogue box appears. A preview of the information in this spreadsheet is 
now shown at the bottom of this dialogue box: 



Tom Brughmans Network Analysis with Cytoscape Tutorial November 2013 

 11 

 

First we need to make sure we map these attributes to the correct network. Click 
on the arrow to the right of ‘Select a Network Collection’ and select ‘Sheet 1’. 
Again, we will have to tell Cytoscape that the first row holds the column labels. 
To do this, tick the box next to Show Text File Import Options and then tick the 
box next to Transfer first line as column names. 

We will not look into more detail at the other options in this box. All you need to 
know for now is that it reads the spreadsheet and attaches all the information for 
a specific code (‘SiteID’) to all nodes in the network with that code. 

Click the OK button. 

Your Cytoscape window does not show the changes immediately. To see the 
node attributes, in the Data Panel click on the show all columns button (third 
from left). Now if you select a node by clicking on it you will see all the 
information we have about that node. 

It might be useful at this point to give each node a label, so that we can 
immediately see what it stands for. Click on the VizMapper tab in the Control 
Panel. Here you can modify every aspect of how a network is visualised. In the 
list of the Visual Mapping Browser there should be the property Node Label. 
Double-click it and change the value in the box next to it to ‘Site name’ (NOT 
shared name). Make sure the Mapping Type is set to Passthrough Mapping. This 
will give each node a unique label based on the node attributes spreadsheet. 
Now when you zoom into your network you will see that each node has a label (if 
this is not the case just change the Mapping Type to Continuous Mapping and then 
back to Passthrough Mapping). 

Save your session! 
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4. Filter network 
At this point we have all the lines of sight between 190 sites represented as one 
single network. The network looks like a very complicated cluster of 
connections, however. It is not easy to say anything meaningful about it without 
using some analytical techniques (see section 6), layout algorithms (section 5) or 
simplifying it. In this section we will see how we can use filters to make a 
selection from the network and simplify it. 

Try to select a number of different nodes and look at their attributes. As we saw 
when looking at the spreadsheets, each site was occupied during different 
periods. We will now create a filter that will allow us to look at just one single 
period. 

In the Control Panel, click the Filters tab. To create a new filter click Option > 
Create new filter. A dialogue box appears, use it to name your filter ‘periods’. 
Next you will have to select those attributes that you want to use in your filter. 
Click on the drop down box next to Attribute/Filter, scroll down and select 
‘node.Iberian’ (this is the node attribute named ‘Iberian’). Then click the Add 
button next to it. Now a new slider will be added in the field below where you 
can select either just 0, 0 and 1, or just 1. When you select 1 (slide the slider to 
the right to make the selection 1:1) you will notice that all sites dated to the 
Iberian period are coloured yellow. Always click the Apply Filter button at the 
bottom left of the screen to make sure your current filter is active. 

This filter allows us to explore exactly those nodes we are interested in and how 
they relate. For example, you can now look at all the attributes of these nodes in 
the Data Panel. 

We can also use filters to create a new network. We will do this now. 

Make sure you have all sites dated to the Iberian period selected (click Apply 
Filter again if necessary). Then click File > New > Network > From Selected 
Nodes, All Edges. This will create a completely new network containing only the 
selected nodes, all the edges between them and holding all the information on 
those nodes and edges. Go to the Network tab in the Control Panel again. You will 
see that our ‘complete network’ now has a child network derived from it named 
‘complete network (1)’. Rename this child network to ‘Iberian’. You can switch 
between the views of the different networks by clicking on them. 

We can also select multiple attributes. This could be useful if we are interested in 
exploring the network of two periods combined. To give a specific example, we 
may want to select nodes that are either dated to Iberian OR Republican times. 
To do this we will have to add another box to our filter (but first make sure that 
the ‘complete network’ is selected in the Network tab, since we will be making 
the selection from this network). Just click the Add button one more time but 
this time with the ‘node.Republican’ attribute selected in the dropdown box. Now 
a second box will be added in the field below. Change this box to only select 
nodes with a value of 1 in this attribute field. 
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Notice how between these two boxes it says AND. This means our filter will only 
select nodes that are dated to the Iberian AND the Republican periods, which is 
not what we want. We will have to change this to OR. To do this click the + sign 
next to Advanced and next to Relation tick OR instead of AND. Notice how the 
AND between the two boxes changes to OR. 

Now we can finally make our selection. Click the Apply Filter button at the 
bottom of the Control Panel. You will notice that the number of nodes 
highlighted in yellow will change. You have now selected all sites dated to both 
the Iberian and the Republican period. 

In the last three sections we will continue to work with the ‘Iberian’ network we 
just created. 

Save your session! 

Exercise 

Make four new networks with only sites dated to the remaining four periods: 
Republican, Early Imperial, Middle Imperial, Late Imperial. Do this by creating a 
filter to select from the ‘complete network’ only sites dated to the relevant 
period and then create a new network. You will need these four networks for the 
exercises below. 

Secondly, it is quite interesting to see exactly which sites are occupied 
throughout all periods in this study and how they are connected in the network. 
This reflects a persistent pattern throughout time and will affect our 
interpretation of the different periods’ networks. Create a filter and networks 
including all sites occupied throughout all periods. 

5. Network layout 
Our Iberian network is still visualised as a rectangle, which is not very 
interesting. Cytoscape offers many alternative layouts that each stress different 
aspects of the network. Most of these are based on the idea that nodes are drawn 
closer together if they are related to each other. This simple rule will produce a 
network visualisation in which you can very often pick out clusters of nodes that 
have a similar structure. In our case it will put sites that are inter-visible with a 
similar group of other sites close together. This type of visualisation can help you 
to explore your dataset and identify data-related issues. For example, one of the 
patterns that often emerge is a dense ball of connections at the centre of the 
network and many nodes at the periphery with a small number of connections. 
This would tell you that the sites at the centre are different in some way to the 
sites at the periphery. More specifically, the sites at the centre are more visually 
prominent than the sites at the periphery. But what does this mean? We should 
stress that identifying a pattern is not the same as explaining the pattern. For 
example, a cluster of sites with a similar assemblage does not necessarily 
indicate cultural, social, economic or political links between these places. 
Patterns identified through visualisations will need to be looked at in detail, and 
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this exploratory network analysis actually allows us to look at the individual 
sites and particular lines of sight that make up the big patterns. The patterns 
identified will also need to be re-contextualised within their archaeological, 
historical and academic frameworks. The value of an exploratory network 
analysis therefore lies in allowing us to identify large-scale patterns in large and 
complex datasets, whilst being critical towards their explanation by being able to 
look at the individual data entities (e.g. a single site, a single line of sight) that 
create these patterns. 

Playing around with different layouts can help us to identify different patterns. 

Save your session before you try any layouts, since some of them are very 
computationally demanding and might cause your PC to crash! 

In Cytoscape you will find all layouts under Layout. Try out the Circular, 
Organic and Random layouts in yFiles. Try to see what the differences are and 
how they allow you to explore different aspects of this network (DO NOT use 
Orthogonal, this might take too long or crash your PC). 

The organic layout works as described above: nodes that are connected are 
drawn closer together, creating a centre and periphery structure. What do you 
think is the logic behind the circular and random layouts? 

Play with different layouts for a while and then select the organic one, which we 
will use in the exercises and sections below. 

Save your session! 

Exercise 

Apply the organic layout to the four other networks. How does the overall 
structure of your network change through time? What can you say about the 
centre of each network? What can you say about the periphery of each network? 
Are there individual sites that are particularly prominent in these networks? 
How does the position of this site on the networks change through time? 

6. Analyse network 
So far we have seen what kind of data networks can be created from, how you 
can import them and how you can explore them using filters and layouts. All of 
this counts as network exploration, we have not yet done any real analysis on the 
networks. There are a range of network measures that can tell you something 
about the role of individual nodes in the network or about the network as a 
whole. Cytoscape has a very easy built-in function that calculates all of the most 
popular measures in one go. In this section we will have a look at this function. 
Please note that the second network analysis practical will deal with these 
measures in more detail. You can also never take the implementation of these 
measures in a particular piece of software for granted. Sometimes very different 
algorithms are used for these measures or different names are given to the same 
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measure, which might lead to different results. Always refer to the software’s 
documentation before performing an analysis. 

By default, Cytoscape uses a plugin called NetworkAnalyzer. To use it click Tools 
> NetworkAnalyzer > Network Analysis > Analyze Network. A dialogue box 
will appear that asks you whether the network is directed or undirected. Select 
directed for this specific network. Click the ok button. This will start the analysis 
and this might take a while. 

A new window appears that holds a wealth of information. On the first tab called 
Simple Parameters you will find some results that tell you something about the 
entire network. The network Diameter, for example, tells you the maximum 
number of steps you can take between two nodes in this network. You can read 
about what these simple parameters mean here: http://med.bioinf.mpi- 
inf.mpg.de/netanalyzer/help/2.6.1/index.html#simple 

The other tabs are charts that summarise a wealth of information. Have a look at 
the Node Degree Distribution and try to interpret this chart using the description 
found here http://en.wikipedia.org/wiki/Degree_distribution and here 
http://en.wikipedia.org/wiki/Scale-free_network . Similarly, have a look at the 
betweenness centrality and closeness centrality charts and interpret them in 
light of the information you find here http://med.bioinf.mpi- 
inf.mpg.de/netanalyzer/help/2.6.1/index.html#nodeBetween and here 
http://med.bioinf.mpi- 
inf.mpg.de/netanalyzer/help/2.6.1/index.html#closenessCent . 

Let’s be clear, however, that these results are completely meaningless unless we 
understand exactly how they were calculated and how the definition of your 
nodes and links (in our case sites and lines of sight) tells you how you should 
interpret these results. This obviously takes quite a bit of time and will be 
different for each archaeological network. This practical merely aims at 
illustrating how to easily analyse a network. 

You can save all these results in a single file by clicking the Save Statistics 
button. Do this now. Try to open the file you just saved with Microsoft Excel. You 
can also easily import these statistics into statistics software like SPSS. 

Close the Network Analysis window and click Yes when asked if you really want 
to close it. Once you have performed an analysis of a network all the results are 
immediately attached to your nodes and edges as attributes. Use the Table Panel 
to explore the results per node. We will use these results in the next section to 
explore the networks from a more analytical point of view. 

Save your session! 

Exercise 

Derive these network analytical measures for the other four networks. Read the 
networkAnalyzer documentation (see links above) and discuss what indegree, 
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outdegree, and number of connected components represent and mean for these 
networks. Compare the average degree and connected components score of all 
five networks. Can you see change in these measures through time? What does 
this trend mean? 

The analyses you perform for all networks will automatically add the results to 
the nodes as attributes. We will use these results below. 

7. Visualise parameters 
You can easily visualise network analysis results you produced earlier by 
clicking Tools > NetworkAnalyzer > Network Analysis > Generate visual 
style from statistics. This will open a new dialogue box where you can select the 
type of measure you want to visualise and how you want to visualise it. For 
example, you could map the node size to its indegree (number of incoming 
connections) and its colour to its outdegree (number of outgoing connections): 

 

Exercise 

Try out a number of different visualisations and use the websites mentioned in 
the previous section to interpret the results. 

Try to find a combination of layout and node-edge visualisation that you believe 
is a particularly interesting way to present your results. 

You can always modify particular properties of you network by using the 
VizMapper tab in the Control Panel. 
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Interpret the changing indegree and outdegree scores of sites through time. 
Which sites have the highest scores for each period? Can you identify sites which 
have a high score in one of these (or both) throughout most periods? Can you 
find an example of a site that has a high indegree but a low outdegree, and vice 
versa? What does this mean? 

Use a filter on the arc attribute field called ‘length’ to create a new network with 
only arcs with a length between 0 and 20km. Derive network analytical 
measures for this new short distance network. How do the indegree, outdegree 
and connected components measures compare with the longer distance 
networks you have analysed earlier? 

Save your session! 
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8. Software resources 
Pajek: http://pajek.imfm.si/doku.php  
Up to date set of analysis techniques, can handle large networks, good manual 
and supporting documentation, less easy to use than UCINET, includes some 
specific features not included in UCINET (Triad counts; nice matrix graphs; 
graphs automatically separating components). 

UCINET: http://www.analytictech.com/ucinet/  
up to date set of analysis techniques, good supporting documentation, great for 
converting to different network data formats. See handout network analysis 
practical 2. 

Cytoscape: http://www.cytoscape.org/  
Poor documentation, user-friendly interface, easy analysis. See handout network 
analysis practical 1. 

Gephi: http://www.gephi.org/  
Verry pretty visualisation, poor documentation, user-friendly interface, manual 
modification of layout algorithm settings. 

GIS: Grass and ArcGIS (networkAnalyzer) have some network features. Can be 
used to produce visibility networks, least-cost paths, etc. 

Processing: http://www.processing.org/  
visualization and animation, programming skills needed. 

Mathematica: http://www.wolfram.com/mathematica/new-in-8/graph-and-
network-analysis/index.html  

Matlab: 
http://www.levmuchnik.net/Content/Networks/ComplexNetworksPackage.htm
l  

R: http://igraph.sourceforge.net/doc/R/00Index.html  
You can do basically anything you want if you can be bothered to code it, some 
great network analysis libraries (network, sna, Rnetworks, igraph, ergm, 
networkDynamic, Rsiena, statnet, tnet). 

Sci2: https://sci2.cns.iu.edu/  

Network workbench: http://nwb.cns.iu.edu/  

Excel and NodeXL: http://nodexl.codeplex.com/  
Everyone knows how Excel works, now you can use it to make networks. 

Python: http://networkx.lanl.gov/ orhttp://igraph.sourceforge.net/ 

http://pajek.imfm.si/doku.php
http://www.analytictech.com/ucinet/
http://www.cytoscape.org/
http://www.gephi.org/
http://www.processing.org/
http://www.wolfram.com/mathematica/new-in-8/graph-and-network-analysis/index.html
http://www.wolfram.com/mathematica/new-in-8/graph-and-network-analysis/index.html
http://www.levmuchnik.net/Content/Networks/ComplexNetworksPackage.html
http://www.levmuchnik.net/Content/Networks/ComplexNetworksPackage.html
http://igraph.sourceforge.net/doc/R/00Index.html
https://sci2.cns.iu.edu/
http://nwb.cns.iu.edu/
http://nodexl.codeplex.com/
http://networkx.lanl.gov/
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TRACER: A text re-use tracing software http://mbuechler.e-
humanities.net/tracer/  

VISONE: http://visone.info/  
Many functions and also runs RSiena 

Blocks: free separate program for blockmodeling - very good at it, does nothing else. 

Result pages somewhat cumbersome, but very good documentation 

http://mbuechler.e-humanities.net/tracer/
http://mbuechler.e-humanities.net/tracer/
http://visone.info/
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